Casual Discussion Science Forum @scivillage

Full Version: Pasting Text
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
For some reason when I copy text and try to paste it when using New Reply all I get is a very very small unreadable line. When I then try to erase it using the backwards x key on iPad it does very slowly while one at a time, each word of the pasted text shows in my predictive words above my keyboard. So I think the pasted line is actually microscopic text. I can copy/paste normally when using the regular reply feature. Has anyone encounter this or has something changed? Did I screw up?
Sounds to me like a scaling issue with the element, If it's something "New" then its likely a setting at your end, if it's something you've been meaning to mention for a while then it could be something in the CSS at this end.

I've added a media-querie entry to the CSS, It will likely cause alsorts of bizarre unwanted effects with all members I apologise for that, but it helps debug what can be done to fix the problem. If you don't suffer any problems then you're running something compatible with that particular method (which is a good thing, the addition originally being toyed with on a dev prototype for making the site more flexible was design to actually be useful rather than cause more problems)

In any event, please report back your findings if you can. (hopefully I've not shrunk the site to the point people can't reply :/)
Going to paste first line of your post...


Quote:Sounds to me like a scaling issue with the element


Whatever you did, works now. Didn’t do anything at my end. I first started noticing the problem at my end a few days ago.
At my end I noticed selected text started following the cursor around like an image used to do. Alerted by this thread I found dragging and dropping the 'image' seems to paste it. deep ignorance and obscurity - pastes ok.
Problem is back. I just can’t take snippets from internet and copy/paste. Well I can but the fonts are so minuscule as to be unreadable. Need a powerful magnifying glass. Any suggestions, problem only occurs on this forum.
(Jun 28, 2022 12:32 AM)Zinjanthropos Wrote: [ -> ]Problem is back. I just can’t take snippets from internet and copy/paste. Well I can but the fonts are so minuscule as to be unreadable. Need a powerful magnifying glass. Any suggestions, problem only occurs on this forum.

Does iPad have any Cut, Copy, and Paste options at all like this, that you can access to manipulate or eliminate the invisible code that's hitching a ride? Big check mark on the last one.
  • Keep Source Formatting

  • Merge Formatting

  • Keep Text Only
To avoid the font size of what you copy and paste being embedded, you have to click on the view source button before you paste it. 
[Image: 52179306726_a60e82e584_w.jpg]
Zin, if you want to avoid altogether dealing with code that gets pasted with the ordinary text, go to your scivillage User Control Panel and click Edit Options. At the bottom under Other Options, check mark the "Put the editor in source mode by default" box.

Thanks to SS for providing the missing piece of the puzzle.

I've always had that box in UCP checked, and long since forgot it existed. Nothing I paste into this forum ever carries (or exhibits) anything but unadulterated text. But I can see how others might like the opposite setting at times, since the original HTML seems to get automatically converted to the forum's BBcode.
I think that last piece of advice did the trick. Let’s see…

Quote:.      “The golden rule that always rocks, expect nothing, appreciate everything” - Unknown
a problem shared is a problem doubled

(humor)

i still do not know what my secret double space code came from
it has not duplicated its self yet
so im guessing it was user error